Thursday, March 12, 2009

Faxing with Asterisk 1.6.1 and SpanDSP

If you're familiar with Digium's Asterisk 1.4x or 1.2x, your fax solution might have included the extremely useful SpanDSP library. Getting a vanilla install of Asterisk from source to "installed" with SpanDSP required a patch and separate downloads ... that is, until recently.

Good News:
Recent versions of Asterisk in the 1.6x line include a combined app_fax support and work with recent versions of SpanDSP.

If you're looking for a place to download app_rxfax.c or app_txfax.c (no longer available from and you're using Asterisk 1.6.x, consider getting a recent version of SpanDSP. For many installs, this will be enough.

No comments: